Ding:Zahnräder mit Inkscape

Aus FabLab Nürnberg Wiki
Wechseln zu: Navigation, Suche
Foto
gears.png
Basisdaten
Status funktionstüchtig
Schöpfer Juewei (Diskussion)


Achtung: Mein Inkscape ist englisch eingestellt. Bitte die Deutschen Begriffe einfach dazu schreiben!

Inkscape -> Extensions -> Render -> Gear

enthält ein einfaches Programm zum konstruieren von Zahnrädern. Die damit gezeichneten Zahnräder lassen sich mit dem Lasercutter in reale Zahnräder verwandeln. Beim Erproben mit Inkscape 0.48 sind einige unschöne Effekte aufgefallen:

Zahnräder mit der Erweiterung gears-dev von Dezember 2011
  • Die Zahnflankenform ist relativ grob. Es gibt pro Zahnflanke einen einzigen Stützpunkt, der die Evolventenform andeutet. Das führt bei Zahnrädern mit wenigen aber grossen Zähnen zu unruhigem Lauf.
  • Der Mittelpunkt ist nicht markiert. Bei ungerader Zähnezahl weicht der Zahnradmittelpunkt vom Objektmittelpunkt in Inkscape ab. Je niedriger die Zähnezahl, um so deutlicher.
  • Die Zahngröße muss in Cricular Pitch Einheiten angegeben werden. Zähnezahl * Circular_Pitch = Teilkreis_Umfang. In Europa ist die Angabe des Moduls gebräuchlicher: Zähnezahl * Modul = Teilkreis_Durchmesser.
  • Die maximale Zähnezahl ist auf 360 begrenzt. Damit kann das Sternenrad in einem Planetarium mit 366 Zähnen nicht gebaut werden.
20 Stützpunkte pro Zahnflanke

Verbesserte Zahnform

In Inkscape 0.49 ist eine neuere Version der gears Erweiterung enthalten. Diese stammt von http://cnc-club.ru/forum/viewtopic.php?f=33&t=434&p=2594#p2500 und wurde bei Debian überarbeitet launchpad#707290

Die Evolventenform der Zahnflanken wird hier sehr genau berechnet, Mittelkreuz und Teilkreis können als Hilfslinien eingezeichnet werden. Ausserdem sind Durchbrüche im Zahnrad (Speichenräder) möglich.

Die letzten beiden der obigen Punkte werden in extended_ranges.patch und metric_module.patch bearbeitet.

Bei Zahnrädern mit sehr hohen Zähnezahlen macht sich die erhöhte Genauigkeit allerdings durch einen langsameren Bildaufbau in Inkscape negativ bemerkbar. Ein Zahnrad mit 230 Zähnen besteht beispielsweise aus über 13000 Koordinatenpunkten. Die hohe Genauigkeit der Flankenform wird durch 20 Punkte pro Zahnflanke erreicht. Dies ist aber nur bei Zahnrädern mit niedrigeren Zähnezahlen wichtig. Daher wird mit selectable_accuracy.patch eine wählbare Genauigkeit von 20, 10, oder 5 Punkten pro Zahnflanke angeboten. Die niedrigste Stufe (5) ist immer noch deutlich besser als das ursprüngliche "Flankendreieck" mit nur einem Punkt auf der Flankenmitte.

Hier die vollständige Erweiterung mit allen Patches zum herunterladen:

Dieses Archiv muss

  • unter Linux im Verzeichnis
    • ~/.config/inkscape/extensions/ oder
    • /usr/share/inkscape/extensions/ entpackt werden. Achtung: Die Dateien gears-dev.py und gears-dev.inx müssen direkt im extensions Verzeichnis landen, ohne weitere Unterverzeichnisse dazwischen.
  • Windows: C:\Program Files\Inkscape\share\extensions\. (englisch)
  • Windows: C:\Programme\Inkscape\share\extensions\. (deutsch)
  • Mac OS X: /Applications/Inkscape.app/Contents/Resources/extensions/.

Nach einem Neustart von Inkscape erscheint im Menü Extensions -> Render ein neuer Eintrag Gear-Dev: gears dev jw1.png

Werkzeug-Korrektur

Laserbahn ausserhalb des grünen Zahnrades

Wird das Zahnrad mit z.B. einem Lasercutter entlang der Zahnflankenkontur ausgeschnitten, so entsteht ein Schnittspalt. Unser Laser hat etwa 0.3mm Spalt, doch das wirkt sich bereits auf die Geometrie aus. Die Mitte des Laserstrahls folgt der programmierten Kontur. Daher zerstört der Laser immer Material zur Hälfte innerhalb und zur Hälfte ausserhalb des Objektes.

Inkscape bietet zwei Möglichkeiten, die Bahnlinie für den Laser so zu veschieben, dass der Strahl ganz ausserhalb der Zahnflankenkontur schneidet:

Stroke to Path

Die folgende Prozedur erfordert einigen Aufwand, ergibt aber exakte Konturen.

  • Zeichne das Zahnrad mit einer Randlinie normalen Randlinie zum Schneiden (0.01mm)
  • (Falls nötig: Pfad -> Objekt in Pfad umwandeln)
  • Dupliziere die Randlinie (Strg-D)
  • Menü Fill and Stroke->Stroke style (Füllung und Kontur -> Muster der Kontur; Shift-Strg-F)
    • Linienstärke auf Durchmesser des Lasers einstellen: Width: 0.3mm
    • Eckenbehandlung auswählbar eckig, gerundet, gefast. Hier ist eckig anzuraten (Join).
  • Path->Stroke to Path (Kontur in Pfad umwandeln), um Punkte an den Linienrändern zu erzeugen.
  • Object->Lower to Bottom (Objekt -> Nach ganz unten absenken), damit die ursprüngliche Linie erreichbar wird.
  • Shift->Auswahl (Mehrfachauswahl) auf die normale Randlinie klicken. Damit sind beide (die neue und die alte Randlinie) ausgewählt.
  • Path->Union (Pfad->Vereinigung), um den inneren Linienrand aufzulösen.

Es entsteht dabei eventuell ein gefülltes Objekt. Die Füllung kann entfernt werden.

Path outset/inset (Schrumpfen/Erweitern (vergrößern))

Für Zahnräder nicht zu empfehlen, aber sehr praktisch falls die Genauigkeit nicht wichtig ist, sind die Funktionen Path->Outset (Vergrößern) CTRL-) und Path->Inset (Schrumpfen) CTRL-(. Sie können eine Pfadlinie nach aussen oder innen versetzen, so dass die alte und die neue Linie überall in etwa(!) den gleichen Abstand haben.

Das erscheint zunächst für die Werkzeugkorrektur geeignet (Versatz um halbe Fräserdurchmesser oder Laserstrahlbreite), hat aber zwei Nachteile:

  • Der Versatz muss in Pixel (px) eingestellt werden. Menü File-> Inkscape Preferences (Datei -> Inkscape-Einstellungen) SHIFT-CTRL-P ->Steps (Schritte). Für einen Versatz von 0.1mm pro Anwendung ist einzugeben: Inset/Outset by: 0.3543 px.
  • Die Qualität des Pfades nimmt ab. Ein Rechteck wird zu einem gerundeten Pfad aus 7 Knoten, die Kanten sind leicht wellig.


Achtung:

  • Nicht machen: Mit Print -> to file PDF (Drucken...-> Datei) rotiert der Linux-Druckerdialog eine querformatige Seite gegen den Uhrzeigersinn. Acroread am Lasercutter-Rechner zeigt an, dass das nun nicht auf die Bearbeitungsfläche des Lasers passt, und bietet automatisches Drehen an. Das funktioniert, aber leider nochmal gegen den Uhrzeigersinn, so dass alles 180° überkopf ausgegeben wird, beginnend in der unteren rechten Ecke.
  • Save a Copy -> PDF (Kopie speichern unter ...) macht es genau richtig! Dort auswählen 'nur Graphik' (nicht ganze Seite). Ein PDF mit wird erzeugt, welches Acroread am Lasercutter nach oben links legt, wo man es erwartet.


Viel Spass damit!

Referenzen