Diskussion:VisiCut

Aus FabLab Nürnberg Wiki
Wechseln zu: Navigation, Suche

Hi, versuche gerade das Plugin zu installieren. Scheitere aber an vielen Stellen aufgrund des aktuellen MacOS (Catalina 10.15.2)

  • Es gibt aktuell keine stable release von Inkscape, der V1 Beta scheint aber zu funktionieren (Startet zumindest)
  • Das aktuelle MacOS unterstützt nicht die verwendete Java Version im VisiCut plugin.
    • Hätte versucht das Plugin zu kompilieren, nach ein paar Anläufen auch hinbekommen, jetzt habe ein fertiges VisiCut.app kann es ausführen, es öffnet sich auch der VisiCut Dialog, aber es installiert sich scheinbar nicht in Inkscape
  • Ok dann das File eben in den Extension-Ordner verschieben. Extension wird zwar angezeigt, aber das extension-error.log meckert des es visicut_export.py nicht findet
  • Datei neben VisiCut.app kopiert und export.py editiert

Eintrag ist nun im Menü und nachdem man "Add to VisiCut" bzw "Open in VisiCut" öffnet wackeln ein paar Icons aber der Dialog öffnet sich nicht



Hallo Markus!

Das Problem mit Java ist bekannt. Ich denke, wir haben da demnächst auch eine Lösung -- Wenn du testen kannst, wäre das super hilfreich, keiner von uns hier hat einen Mac. Du scheinst dich ja auch mit Java ein wenig auszukennen. Das ist sehr gut! Wenn Du mithelfen willst, kannst du mich (juergen@fabmail.org), Klaus oder Thomas gerne per Github, Telegram, oder Email anschreiben, dann setzen wir uns mal gerne zusammen.

Die stable Release von Inkscape heisst 0.92.4 -- mit catalina hat uns Apple neue Stolpersteine in den Weg geworfen. Ich hätte gehofft, dass man wenigstens den MAcPorts build auf catalina zum laufen bekommt. https://inkscape.org/release/inkscape-0.92.4/mac-os-x/macports/dl/ Mit der aktuellen inkscape beta habe ich nooch keine Versuche gemacht. Da muss sicher einiges am Plugin-Code (python script) umbauen. --Juewei (Diskussion) 00:32, 14. Jan. 2020 (CET)